Knowledgebase: outmail
How do I install the anti-spam agents on a Hub Transport for MS Exchange 2007 & 2010?

Problem:

How do I install the anti-spam agents on a Hub Transport for MS Exchange 2007?
How do I install the anti-spam agents on a Hub Transport for MS Exchange 2010?

Solution:

This solution is for Exchange Servers running without an Edge Transport Server. The solution below is for installing the anti-spam agents on a Hub Transport Server. It is assumed that you already have a installed and working Exchange System.

To install antispam agents on a Hub Transport server:

  1. Start the Exchange Management Shell (EMS)
  2. Navigate to the \Exchange Server\Scripts folder (by default C:\Program Files\Microsoft\Exchange Server\Vxx\Scripts)
  3. Run the Install-AntispamAgents script:

    .\install-antispamagents.ps1

Verify Install:

You can verify the install worked correctly by going to Organization Configuration > Hub Transport node in the EMC. From there you should now see a tab called Anti-spam, as per the diagram below.

Exchange Anti-Spam Tab in the Hub Transport

Note:

If you're using Exchange Server in a topology with an Edge Transport server, the anti-spam agents, Connection Filtering, Content FilterSender ID, Sender Filter, Recipient Filter, and Protocol Analysis are ready installed on the Edge Transport server.

Therefore you don't need these agents installed on the Hub server(s).

(47 vote(s))
Helpful
Not helpful





Disclaimer
The Origin of this information may be internal or external to Prolateral Consulting Ltd. Prolateral makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Prolateral makes no explicit or implied claims to the validity of this information. Any trademarks referenced in this document are the property of their respective owners.